No Tavern on 4G

I'm not sure whether this is a phone problem (Pixel 2XL, running Android Pie (?) and Chrome as my browser) or a Tavern problem, but I cannot get the Tavern to load when I am using a 4G signal. When I am logged into a wireless system at home or at work, its fine. Once I go off that however, it just will be connect.

Any advice for a Taverner on the go?
The error message says

The site can't be reached unexpectedly closed the connection

Try: checking the connection


{and the details section says...}

Check your internet connection
Check any cables and reboot any routers, modems or other network devices you may be using

The Tavern is the only site that I have this problem with.
Almost certainly if you have the same provider that others have mentioned as working then it comes down to a weird configuration thing on the phone. If it used to work then a recent upgrade may have screwed things up.
I've tried all of the online solutions for this sort of thing; clearing caches etc. Reinstalling Chrome etc. Nothing seems to work. I think I'll just have to accept that I'm destined to only enjoy the warm friendly environs of the Tavern from my own home (or work....)

Thanks for trying to help
One possibility is, but I'll admit it is a slim one, is that your account has the parental filter on and The Tavern has recently been added to a block list that EE uses (someone mentioned recently that The Tavern had been classified as a gaming site but one of the filter companies) and that instead of giving you a nice warning, EE are just dumping the connection and you are seeing the standard browser error message.

As I said slim. The only way to check would I suspect to be to call EE customer service and ask them to make sure your number allows any and all content, but that means spending time on the phone with a mobile operator's customer service, a special kind of hell I wouldn't wish on anyone.

So going without The Tavern when out and about may be the better option...

- Neil.


The Guvnor
Staff member
We tried Neil's SIM in my phone and the same behaviour was exhibited so I am convinced EE are fucking with Neil's internet.
Last edited: